Installation

ObjectQL requires Python 3.5 or newer.

Install ObjectQL with pip:

pip install objectql

Install ObjectQL with pipenv:

pipenv install objectql

Dependencies

ObjectQL has a few lightweight dependencies that will automatically be installed when installing ObjectQL.

  • graphql-core the core GraphQL base implementation in Python.

  • requests a lightweight HTTP request library

  • typing-inspect introspection on type defintions in Python.